I just stumbled upon this one on a new machine I was working with:  

Are you trying to install the Windows Management Framework 5 Preview, to get all the new PowerShell stuff, and see an error like this one?

"The update is not applicable to your computer"


This preview actually requires the system local to be set to "en-US", you can easily check this using Get-Host within PowerShell:


In my example, the CurrentUICulture was set to "en-GB" and, apparently, that's why the update failed to install. Once I changed my regional settings and downloaded the "en-US" language pack, the update installed just fine.

In case you haven’t heard of the preview as of yet, you can grab it here: http://www.microsoft.com/en-us/download/details.aspx?id=44070

The issue is also listed in Connect: https://connect.microsoft.com/PowerShell/feedback/details/877188/update-is-not-applicable-to-your-computer-windows-management-framework-5-0-preview-may-2014


Have fun,

This post has been migrated from our earlier blog based on BlogEngine.NET.